This issue was fixed in Version 1.2 – May 4th, 2018


Apparently Firebase did a massive change to their libraries on 2nd May. This is causing an error in the template for some reason.

To solve you have 2 steps:


1) In build.gradle replace line 13 & 14 to:

classpath 'com.android.tools.build:gradle:3.1.2'

classpath 'com.google.gms:google-services:3.2.1'


2) In app/build.gradle replace lines 42-55:

implementation 'com.google.android.gms:play-services-ads:15.0.1'

implementation 'com.google.android.gms:play-services-analytics:15.0.2' 

implementation "com.google.android.gms:play-services-location:15.0.0" 

implementation 'com.google.firebase:firebase-core:15.0.2' 

implementation 'com.google.firebase:firebase-messaging:15.0.2' 

implementation 'com.android.support:appcompat-v7:27.1.1' 

implementation 'com.android.support:exifinterface:27.1.1' 

implementation 'com.android.support:design:27.1.1' 

implementation 'com.android.support:cardview-v7:27.1.1' 

implementation 'com.android.support:recyclerview-v7:27.1.1' 

implementation 'com.android.support.constraint:constraint-layout:1.1.0' 

implementation 'com.android.volley:volley:1.0.0'